File Explorer shows a drive with a network mounting point as 'Disconnected'.
Problem
A network mounting point is created and accessible, yet File Explorer shows the corresponding drive letter as 'Disconnected'.
Background
CBFS Connect and other products use a Helper DLL to perform a variety of functions, such as updating File Explorer's cache with the state of a drive. If a drive is accessible, but File Explorer reports the drive is 'Disconnected', then it is possible the Helper DLL did not properly load into File Explorer.
Potential Causes
Steps To Take
The Helper DLL did not load into memory
Ensure that the MODULE_HELPER_DLL flag is included when calling the Install method or function. Afterwards, restart File Explorer.
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Check whether File Explorer loads the helper DLL in memory using by SysInternals Process Explorer.
Choose the process (explorer.exe) and in the bottom pane see the list of DLLs.
If the bottom pane is not shown, it should be enabled in the menu, View->Show Lower Pane (mark it), then choose "DLLs" in the View->Lower Pane View submenu.
The list of DLLs should include "cbfsShellHelper22.dll" for CBFS Connect version 2022; for other versions or products, the name will be similar.
Issue with NetworkProvider Registry Key
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Inspect the list of network providers in the registry.
Use RegEdit to go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider.
Look for three subkeys: HwOrder, Order, ProviderOrder.
Verify each subkey has "cbfs22" (CBFS Connect 2022) or the string matching your version.
If missing, manually add the string to the registry and restart explorer.
Always remember that the specific problem you encounter may have a different cause or require a different solution than those listed above.
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